Sistema de Hostpot para áreas públicas com cartão voucher | AcessoWi-Fi

Sistema de Hostpot para áreas públicas com cartão voucher

Download PDF

Saudações amigos AcessoWi-Fi!

Hoje venho abordar uma situação que muita gente enfrenta e normalmente não quer gastar muito dinheiro com softwares de gestão para poder implantar isso em áreas públicas.
Imagine um hotspot em uma praça de alimentação de um shopping ou no pátio de uma escola por exemplo. Você pode mandar fazer alguns cartões personalizados deixando ainda mais profissional o seu serviço com um código tipo “raspadinha” para garantir que ninguém vá usar sem sua permissão.

Você vai precisar de uma routerboard (pessoalmente recomendo uma RB433AH) com um cartão em 2.4ghz (recomendo um R52H ou XR2) e uma antena omni de 8dbi ou mais. Também vai precisar do link de interrnet e uma caixa para montagem de tudo dentro, uma fonte e se possível um no-break para garantir maior segurança em caso de falta de energia, pigtail para ligar o cartão na antena e conhecimento de como montar um hotspot no mikrotik.

Após montado o hotspot, você usa o seguinte script:

:global content [/file get [/file find name=voucher.txt] contents] ;
:global contentLen [ :len $content ] ;

:global lineEnd 0;
:global line “”;
:global lastEnd 0;

:do {
:set lineEnd [:find $content “\r\n” $lastEnd ] ;
:set line [:pick $content $lastEnd $lineEnd] ;
:set lastEnd ( $lineEnd + 0) ;

:local tmpArray [:toarray $line] ;
:if ( [:pick $tmpArray 0] != “” ) do={
:put $tmpArray;
/ip hotspot user add profile=1HS name=[:pick $tmpArray]
/ip hotspot user remove [find name=”\r”]
}

Após isso, você deverá criar um arquivo txt em seu pc com o nome de voucher (vouchers.txt) e dentro dele colocar senhas que você pode gerar com facilidade no site http://www.random.org/passwords/ .

Feito isso, salve o arquivo e envie para seu mikrotik.

execute o script toda vez que for adicionar novos vouchers; não esqueça de enviar um arquivo vouchers.txt toda vez que for adicionar mais cartões.

você pode mandar fazer os cartões tipo raspadinha no site www.raspacard.com.br para ter um trabalho bem feito e de forma profissional.

Gostou? Indique aos amigos e não deixe de nos visitar, sempre temos atualização com muito conteúdo útil.

Créditos do script: David Marcony (facebook) e a mim por modificar algumas coisas e trazer para o blog (Julio Cesar Rossoni).


  • Nosso blog te ajuda? Ajude-nos também!

    Se nosso blog tem lhe ajudado, ajude a manter o site no ar!

  • Meu IP

  • IPv4 e IPv6 no mundo

  • Assinar blog por e-mail

    Digite seu endereço de e-mail para assinar este blog e receber notificações de novas publicações por e-mail.

  • Recursos Online

  • Seo wordpress plugin by www.seowizard.org.