Criando um servidor de log | AcessoWi-Fi

Criando um servidor de log

Download PDF

Vejo que um grande problema de muitos servidores é não saber administrar corretamente a rede, seus logs e acessos. Por este motivo vou ensinar neste post como fazer um servidor de log usando UBUNTU em sua rede.

Instalação:

a) Instalação e configuração do servidor (Ubuntu 10.04):
1. Abra o VirtualBox e inicie a máquina virtual do Ubuntu 10.04.
2. Instale o LAMP:

$ su
# apt-get install lamp-server^

Digite a senha de root para o MySQL 2 vezes (“seginfo“)

4. Instale o rsyslog e seu módulo relp:

# apt-get install rsyslog-mysql rsyslog-relp

5. Selecione <Sim>, digite a senha de root do MySQL (“seginfo“) e entre com a
senha do rsyslog 2 vezes (“seginfo“).

6. Descomente a as linhas do arquivo ‘/etc/rsyslog.conf’ para habilitar o
recebimento de logs por TCP e UDP:

# vi /etc/rsyslog.conf

….
# provides UDP syslog reception
$ModLoad imudp
$UDPServerRun 514

# provides TCP syslog reception
$ModLoad imtcp
$InputTCPServerRun 514
….

7. Salve o arquivo.

8. Reinicie o serviço.

# service rsyslog restart

9. Verifique se o rsyslog está gravando no MySQL.

# mysql -p -e “SELECT * FROM Syslog.SystemEvents;”

10. Digite a senha do MySQL: “seginfo

….

| 1 | NULL | 2011-03-30 11:27:29 | 2011-03-30 11:27:29 | 0 | 6 | seg | imklog 4.2.0, log source = /proc/kmsg started. 

….

11. Crie o arquivo ‘/etc/rsyslog.d/relp.conf‘ e adicione as duas linhas
abaixo.

# vi /etc/rsyslog.d/relp.conf

$ModLoad imrelp
$InputRELPServerRun 20514

12. Salve o arquivo.

13. Crie um diretório de trabalho para o rsyslog.

# mkdir -p /var/rsyslog/work

14. Adicione as linhas abaixo no ‘/etc/rsyslog.d/mysql.conf‘.

# vi /etc/rsyslog.d/mysql.conf


# Buffering stuff:
$WorkDirectory /var/rsyslog/work # default location for
work (spool) files
$ActionQueueType LinkedList # use asynchronous processing
$ActionQueueFileName dbq
# set file name, also enables
disk mode
$ActionResumeRetryCount -1
# infinite retries on insert
failure

15. Salve o arquivo.

16. Reinicie o serviço.

# service rsyslog restart

17. Baixe o loganalyzer-3.0.1.

# wget http://download.adiscon.com/loganalyzer/loganalyzer-3.6.2.tar.gz

18. Descompacte o LogAnalyzer.

# tar xzf loganalyzer-3.6.2.tar.gz

19. Copie os arquivos necessários para o servidor Web (Apache).

#

cd loganalyzer-3.0.1

mkdir /var/www/logs

cp -R src/* /var/www/logs/

cp contrib/* /var/www/logs/

cd /var/www/logs/

chmod +x configure.sh secure.sh

./configure.sh

#

20. Crie um banco de dados para os usuários.

# mysql -p

mysql> create database LogAnalyzerUsers;
mysql> grant all on LogAnalyzerUsers.* to teste@’localhost’
identified by ‘seginfo’;
mysql> quit

21. Reinicie o Apache2.

# /etc/init.d/apache2 restart

22. Abra um browser e vá para http://localhost/logs/

23. Clique sobre o texto “here” conforme figura abaixo para iniciar as configurações
do LogAnalyzer.

img1

24. Clique no botão <Next> no “Step 1” e no “Step 2“.

25. Deixe o “Step 3” conforme figura abaixo.

img2

26. Clique <Next> no “Step 4” e “Step 5“.

27. Crie a conta do administrador no “Step 6“.

User: root
Password: seginfo

28. Deixe as configurações finais conforme abaixo:

img3

29. Clique sobre o texto “here” para finalizar as configurações.

30. Faça o login como usuário “root” e senha “seginfo“.

img4

31. Configure o “Set auto reload” para <10 seconds>.

 

Autor: Alexsander Loula (alex.loula@gmail.com)
Data: 28/03/2011
Versão: 0.1

 

Agora vem o como adicionar ele a seu servidor Mikrotik:

/ip firewall nat
add action=log chain=dstnat disabled=no dst-address=!192.168.14.0/24 log-prefix=DESTINO protocol=tcp

/system logging action
set remote bsd-syslog=no name=remote remote=192.168.14.101 remote-port=514 \
src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=\
remote

/system logging
add action=remote disabled=no prefix=”” topics=firewall,info
add action=remote disabled=no prefix=AUTH topics=hotspot,account,info
add action=remote disabled=no prefix=AUTH topics=hotspot,debug,info

 

obs: em set remote bsd-syslog=no name=remote remote=192.168.14.101 remote-port=514…

remote=[ipdoservidor]

DICA:

Para maior segurança add essa regra no firewall se seu servidor de log se ele for apenas servidor de log:

iptables -A INPUT ! -s 192.168.14.10 -j DROP

 

192.168.14.10= IP do mikrotik ou seja ele so vai aceirtar entrado apenas do servidor mikrotik para a gravação de log.


  • Nosso blog te ajuda? Ajude-nos também!

    Se nosso blog tem lhe ajudado, ajude a manter o site no ar!

  • Meu IP

  • IPv4 e IPv6 no mundo

  • Assinar blog por e-mail

    Digite seu endereço de e-mail para assinar este blog e receber notificações de novas publicações por e-mail.

  • Recursos Online

  • Seo wordpress plugin by www.seowizard.org.